BlackBerry Tips

Tips 'n' Tricks for BlackBerry Enterprise Server and BlackBerry Handheld devices.

 

1. On your BlackBerry, go to the Address Book.

2. Open it and click (or press Menu on 8100, 8800, 8300) to see SIM Phone Book.

3. Click SIM Phone Book. The list of your SIM contacts will appear.

 

  • From here you have 2 options:

                  You may choose to highlight one contact and click to ADD TO ADDRESS BOOK

 

          - or -

                  You can COPY ALL TO ADDRESS BOOK.

 

  • Please note that SIM contacts will ONLY contain one phone number per contact entry.
  • It is by default that ALL contacts from your SIM card will copy to your BB Address Book as "Work Phone". This cannot be changed, you will need to edit the information to arrange it correctly.

In order to backup the BlackBerry Configuration Database on a BlackBerry Enterprise server, you should  

  1. Create a folder on the root of the C drive called backup
  2. Within that folder create a file called DBBackup.BAT
  3. Edit the file with notepad and add the following text
osql -E -Q "backup database besmgmt to disk='c:\backup\besmgmt.bak'"

Set CURRDATE=%TEMP%\CURRDATE.TMP
Set CURRTIME=%TEMP%\CURRTIME.TMP

DATE /T > %CURRDATE%
TIME /T > %CURRTIME%
Set PARSEARG="eol=; tokens=1,2,3,4* delims=/, "
For /F %PARSEARG% %%i in (%CURRDATE%) Do SET YYYYMMDD=%%l%%k%%j
Set PARSEARG="eol=; tokens=1,2,3* delims=:, "
For /F %PARSEARG% %%i in (%CURRTIME%) Do Set HHMM=%%i%%j%%k

RENAME c:\backup\besmgmt.bak besmgmt_%YYYYMMDD%%HHMM%.bak

 

Note: if the Database is not called BESMgmt then you will need to change the name of the database within the first line of the script.

  • If you want you can then create a Scheduled Tasks within Windows to run the bat file to backup the database.

RIM has a secret little menu hiding within your BlackBerry as long as its running OS 4.2 or higher.

This little secret is a self diagnostic tool, which will help you figure out if something is wrong with your device. To access this menu simply:

 

1. Go to Options

 

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2. Go to Status

 

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 3. In the Status screen, type test once

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4. The diagnostic screen appears.

5. Click on the Thumbwheel (or the BlackBerry button)

6. Click on Start.

 

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7. Select the tests that you want to run, and click on the Run button. You have the ability to test numerous aspects of you BlackBerry Handheld Device (smart phone)

 

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Sample Keyboard Test

 

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Sample Trackball Test

 

When you try to download content to the BlackBerry smartphone, you receive a 909 error message.

If you used the Backup and Restore tool or the Device Switch Wizard in BlackBerry® Desktop Manager to transfer data from an older device, some of the security certificates required to download content may have been overwritten with older certificates.

Step 1: Backup the BlackBerry smartphone using the BlackBerry Desktop Manager
  1. Open BlackBerry Desktop Manager.
  2. Connect the BlackBerry smartphone to the computer.
  3. Open BlackBerry Desktop Manager.
  4. Double-click Backup and Restore.
  5. Select Backup.
  6. Choose a location to save the backup file, then click Save.

Step 2: Clear the Certificates Database
  1. In the BlackBerry Desktop Manager, double-click Backup and Restore.
  2. Select Advanced to backup specific databases.
  3. Select File > Open.
  4. Select the .ipd file and click Open.
  5. In the left hand pane, highlight the Handheld Key Store database, then click Delete.

Step 3: Perform a security wipe on the BlackBerry smartphone
  1. On the Home screen, click Options.
  2. If you are running BlackBerry® Device Software 4.1 or later, click Security Options > General Settings. For versions of BlackBerry Device Software earlier than 4.1, click Security.
  3. Open the menu and select Wipe Handheld > Continue.
  4. Type blackberry, then press Enter. All the data on the BlackBerry smartphone is deleted.
Step 4: Restore the data to the BlackBerry smartphone
  1. Connect the BlackBerry smartphone to the computer running BlackBerry Desktop Manager.
  2. Open BlackBerry Desktop Manager.
  3. Double-click Backup and Restore.
  4. Select Restore to restore the data to the BlackBerry smartphone.
  5. Choose the appropriate .ipd file, and click Open.

You can use the BlackBerry smartphone as a tethered modem to connect a computer to the Internet. The wireless connection between the BlackBerry smartphone and the computer can be made using Bluetooth technology.

  1. Set the Bluetooth wireless technology to Discoverable mode on your BlackBerry smartphone.
  2. Pair your BlackBerry smartphone with your computer.
  3. Set up the Internet Access Point Name (APN) (one time only).
  4. Configure dial-up networking (one time only).
  5. Connect to the Internet using dial-up networking.

 

Problem

The BlackBerry smartphone user receives the following error on the BlackBerry smartphone during the enterprise activation process:

IT Policy Rejected. Please wipe handheld and try again.

The BlackBerry smartphone rejects the IT policy that is pushed by the BlackBerry Policy Service.

 

Cause

The BlackBerry smartphone was activated on another BlackBerry® Enterprise Server that did not share the same database. If an IT policy is applied to a BlackBerry smartphone, then it cannot be overwritten. 

 

Resolution

To overwrite the IT policy, perform either a security wipe on the BlackBerry smartphone or re-install the BlackBerry Device Software.

Complete the following steps to perform a security wipe on the BlackBerry smartphone.

Warning: The following procedures will delete either all data, or all data and applications on the BlackBerry smartphone. Back up the data prior to performing the procedure. For instructions, see KB12487.

  1. On the BlackBerry smartphone, go to Options > Security Options > General Settings.
  2. Open the menu and select Wipe Handheld.
  3. Click Continue.
  4. Type blackberry, and then press Enter. Note: If you have turned on content protection, the process for deleting all the data on the BlackBerry smartphone can take up to an hour to complete. Do not remove the battery from the BlackBerry smartphone while data is being deleted.

 

 

BlackBerry Enterprise Server v4.1 provides the ability to export your user statistics should you need them for reporting purposes.

The following fields are exported by default, regardless of the columns displayed in BlackBerry® Desktop Manager.

  • Display Name
  • PIN
  • Enabled State
  • Forwarded
  • Sent from Device
  • Pending to Device
  • Expired Filtered
  • Mailbox DN

The following columns are displayed by default in the User tab.

  • Name
  • PIN
  • Status
  • Last Connect Time
  • Group Name
  • Server Name

To export statistics for multiple BlackBerry® smartphone users, hold the ALT key and select the desired BlackBerry smartphone user accounts.

If information other than that in the default fields is required, it will be necessary to use a script to extract the required information from the BlackBerry Configuration Database.

 

To turn off the network coverage LED indicator, perform the following:

  1. From the Home screen of the BlackBerry smartphone, click Options > Screen/Keyboard.
  2. Highlight the LED Coverage Indicator field, and then open the menu.
  3. Click Change Option.
  4. Select Off.
  5. Open the menu, and then click Save.

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