BlackBerry Enterprise Server TechNotes

Information relating to the installation and configuration of BlackBerry Enterprise Server 4.x and 5.x mobile messaging platform.

 

A blank IT policy can be sent to the BlackBerry smartphone to update an existing IT policy setting. This is useful when transferring BlackBerry smartphones between users in different companies, where different IT policies are enforced.

A blank IT policy can be created with no settings applied, and sent to the BlackBerry smartphone by a system administrator.

Alternatively, contact your system administrator. Depending on the BlackBerry Enterprise Server software version, the BlackBerry smartphone model, and the IT security policy that your organization adopts, the IT policy may be removed by the administrator.

 

 

Note: For a multiple BlackBerry Enterprise Server environment sharing one database, you should stop all Services on all Servers while performing the first upgrade to properly update the database schema. You only need to stop the Services on the first update and any other that has you going to a different version of BlackBerry Enterprise Server software version or Maintenance release then that of the first update.

Step 1: Download the Latest BlackBerry Enterprise Server Service Pack

  1. Go to http://www.blackberry.com/support/downloads/ and click the Download link in the Download BlackBerry Software section.

  2. From the drop-down list, select your BlackBerry Enterprise Server version and platform,  click Next.

  3. Locate the latest service pack in the products list and click Download.

  4. Save the installation file to the hard disk.

  5. When the installation file finishes downloading, rename the file extension from .exe to .zip.

  6. Extract the ZIP file to a subfolder. You will install the software from this folder.

  7. In the extracted folder, locate the Docs folder.

  8. In the Docs folder, open the admin.pdf file.

  9. The admin.pdf file contains the software requirements for the new service pack.  For reliable performance, verify that all the software requirements are met.

 

Step 2: Confirm and Back Up Configuration Settings and CALs

  1. Click Start > Programs > BlackBerry Enterprise Server > BlackBerry Server Configuration.

  2. Copy and paste the following information from the BlackBerry Server Configuration tool into a Notepad file.

    BlackBerry Server Configuration tool location Data to record in Notepad
    Database Connectivity tab

    Microsoft® SQL Server™ name
    Database name


    BlackBerry Server tab
    SRP Identifier
    SRP Authentication Key
    Host Routing Information (if applicable)
    GroupWise Settings tab Novell GroupWise Server and Port
    Admin User
    Trusted Application Key
    Application Name (for Service Pack 3 and later)

  3. Save and close the Notepad file.

  4. On the computer hosting the BlackBerry Configuration Database, open a command prompt.

  5. At the command prompt, type the following:
    C:\ BCP "use besmgmt; select licensekey from licensekeys where licensekeys.type = 0" queryout c:\keys.txt -c -T
  6. Copy the keys.txt file to the computer hosting the BlackBerry Enterprise Server.

Step 3: Back Up the BlackBerry Configuration Database

Back up the BlackBerry Configuration Database using one of the following methods:

  1. Use Microsoft SQL Server Enterprise Manager.

    OR

  2. Open a command prompt on the computer hosting the BlackBerry Configuration Database and type the following commands:

    osql -E
    1> backup database besmgmt to disk = "c:\backup_before_upgrade.bak"
    2> go
    1> quit

Step 4: Stop BlackBerry Services and Record Logon Account Information

  1. In the Control Panel, go to Administrative Tools > Services.

  2. Stop each BlackBerry service.

  3. For each BlackBerry service, do the following:

    • Open the Properties window and change the Startup type to Manual.
    • Click the Log On tab. Record the account name in the This account: field in the Log on as: section.

      Warning: For the BlackBerry Attachment Service, always log on with the Local System Account. Do not change this setting.

    Important: Restarting certain BlackBerry Enterprise Server services will delay email message delivery to BlackBerry smartphones. For more information, see KB04789.

  4. Restart the BlackBerry Enterprise Server.

    Warning: Restarting the BlackBerry Enterprise Server will delay email message delivery to BlackBerry devices. For more information, see KB04789.

  5. Log in to the local computer only, using the account specified for BlackBerry services. (For Novell GroupWise, Novell NetWare® connections are not necessary.)

Step 5: Install the Service Pack

  1. In the Control Panel, go to Administrative Tools > Services.

  2. Confirm that all BlackBerry services are not started. They should still be set to start manually.

  3. When performing a Version or Maintenance Release upgrade in an environment with more than one BlackBerry Enterprise Server sharing the same database, it is necessary to stop the Services on all the BlackBerry Enterprise Servers. Once the database has been upgraded and you wish to upgrade the remaining BlackBerry Enterprise Servers to the same version, you can then leave the Services running as the database has already been upgraded.

  4. Open the subfolder to which the ZIP file was extracted.

  5. Double-click setup.exe to start the installation.

  6. After the installation process is complete, you must complete the Database Configuration Wizard.

  7. Make sure that all the fields in the Database Configuration Wizard are complete and confirm that the prepopulated fields match the previous settings. Refer to the information you recorded in the Notepad file.

  8. With the Start Services option selected, click Finish.

    Note: If you plan to install hotfixes for the service pack, clear the Start Services option before clicking Finish. After clearing this option, proceed with the hotfix installation. Refer to KB04907 for information on installing a BlackBerry Enterprise Server hotfix.

  9. In the Control Panel, go to Administrative Tools > Services.

  10. Confirm that all BlackBerry services are started. The startup type should now be set to Automatic.

  11. Open BlackBerry Manager.

  12. Select the BlackBerry Enterprise Server instance that was upgraded and click the Server Configuration tab.

  13. Confirm that the SRP Status is Connected.

User cannot send messages because the Send As permission has been revoked

Environment

  • BlackBerry® Enterprise Server software versions 3.6 through 4.1
  • Microsoft® Exchange Server 2003 Service Packs 1 and 2
  • Microsoft Exchange Server 2000 Service Pack 3
Background

This article applies to Microsoft Exchange Server 2003 and 2000 within the following environments:
  • Microsoft Exchange Server 2003 Service Pack 1 using store build 7233.51 or later
  • Microsoft Exchange Server 2003 Service Pack 2 using store build 7650.23 or later
  • Microsoft Exchange Server 2000 Service Pack 3 using store build 6619.4 or later
Important: When you apply the hotfix described in Microsoft Support Knowledge Base article 895949 to Microsoft Exchange Server 2003 Service Pack 1 or Service Pack 2, or apply the hotfix to Microsoft Exchange Server 2000 Service Pack 3, see KB12827.

Problem

When a BlackBerry device user tries to send a message, a red X appears beside the message in the Messages list indicating it cannot be sent. The Message Status field displays one of the following errors:
  • Unlisted message error
  • Desktop email program unable to submit message.

 

Note: The Message Status field appears above the To field within the message.

 

Cause

When applying the hotfix described in Microsoft Support Knowledge Base article 895949 to Microsoft Exchange Server 2003 Service Pack 1 or Service Pack 2, or applying the hotfix to Microsoft Exchange Server 2000 Service Pack 3, the store.exe utility revokes the Send As permission for all Microsoft Exchange Server administration accounts that have been granted Administer Information Store permission at the mailbox store level.

Note: For additional causes and resolutions related to this problem, please see KB00274.

Resolution


Depending on whether you have applied the Microsoft hotfix, complete the appropriate resolution below.

Resolution 1


If you have not applied the Microsoft hotfix, check the permission requirements. For information on resolving the permission requirements, search for article 912918 in the Microsoft Support Knowledge Base.
Note: You do not need to restart any BlackBerry services.

Resolution 2


If you have applied the Microsoft hotfix, complete the steps below for the appropriate software version of the BlackBerry Enterprise Server.

BlackBerry Enterprise Server software version 4.0 through 4.1

  1. Check the permission requirements. For information on resolving the permission requirements, search for article 912918 in the Microsoft Support Knowledge Base.

  2. In Microsoft Windows® Control Panel, open Administrative Tools > Services.

  3. Right-click BlackBerry Router, click Stop, and wait for 20 minutes.

  4. Right-click BlackBerry Router, then click Start. This will clear the Microsoft Exchange Server permissions cache for the BlackBerry Enterprise Server administration account.
Note: The default time for which permissions are cached is controlled by the Mailbox Cache Age Limit registry entry. Therefore, the amount of time needed for clearing the permissions cache depends on the value that has been set for this registry entry. Microsoft recommends changing the default time of two hours (120 minutes) for clearing the permissions cache to 20 minutes. The value for the Mailbox Cache Age Limit registry entry may be different in other environments. Refer to this value to determine how long permissions are cached for the administration account. Make sure you wait the amount of time set in the Mailbox Cache Age Limit registry entry to allow the permissions cache to clear. For other options, search for article 912918 in the Microsoft Support Knowledge Base.
For more information about the Mailbox Cache Age Limit registry entry, search for article 327378 in the Microsoft Support Knowledge Base or search for the Mailbox Cache Age Limit registry entry in the Microsoft TechNet web site.

Important: Restarting certain BlackBerry Enterprise Server services will delay message delivery to BlackBerry devices. For 
more information, see KB04789.
Protected Accounts

If the Send As permission is revoked from a Microsoft Active Directory® user account because that user object shares a membership with a protected account, complete the following steps:
Note: For more information and a complete list of protected accounts, search for article 907434 in the Microsoft Support Knowledge Base.
  1. Remove the protected account membership from the Microsoft Active Directory user object.

  2. Assign the Send As permission to the user object again. For instructions, search for article 912918 in the Microsoft Support Knowledge Base.

  3. Wait for Microsoft Active Directory replication to occur, or force the replication.

  4. Do one of the following:

    • Remove the BlackBerry device user from the BlackBerry Enterprise Server, then wait 20 minutes. Add and activate the BlackBerry device user on the BlackBerry Enterprise Server again.

    • Depending on the software version of the BlackBerry Enterprise Server, stop the BlackBerry Router or the BlackBerry Enterprise Server, then wait 20 minutes. Start the BlackBerry Router or the BlackBerry Enterprise Server again. Important: Restarting certain BlackBerry Enterprise Server services will delay message delivery to BlackBerry devices. For more information, see KB04789.

Additional Information

It is possible to modify Active Directory permissions to allow BlackBerry device users who are members of protected groups to send messages from their BlackBerry devices without creating secondary email accounts. For instructions on modifying the permissions that are associated with the AdminSDHolder Active Directory object and have been changed by the recent Microsoft Exchange update, search for article 817433 in the Microsoft Support Knowledge Base.

Important: This procedure is not recommended by Microsoft or by Research In Motion.

2007 Daylight Saving Time (DST) patch and the Send As permission

With the new collaboration data object (CDO) update from Microsoft, each BlackBerry device user in the Active Directory must have the Send As permission enabled in the BlackBerry Enterprise Server administration account. If the Send As permission is not enabled in the administration account, the BlackBerry device user cannot send messages from the BlackBerry device.

When adding a new BlackBerry device user to the BlackBerry Enterprise Server, administrators should make sure that the Send As permission is enabled in the BlackBerry Enterprise Server administration account within Active Directory. When a new BlackBerry device user is added to the BlackBerry Enterprise Server, the BlackBerry device user must either inherit the Send As permission from a parent object in Active Directory (for example, through a group permission), or the BlackBerry device user must have this permission set automatically by the BlackBerry Enterprise Server. If this does not occur, use the SetSendAsPermission tool to set the permission.

To download the SetSendAsPermission tool, click here. For instructions on using the SetSendAsPermission tool, see KB12300.

 

Problem Description

When attempting to start the BlackBerry Enterprise Server, the following error appears:

Unable to get address book list (The remote server is not a known TCP/IP host. 0x1C63).

When attempting to start BlackBerry Enterprise Server software version 4.0 Service Pack 2 (4.0.2) Bundle 12 or later, the following error message appears:

Unable to get address book list - will try again in 1 minute (The remote server is not a known TCP/IP host. 0x1C63).

Following the error message, the BlackBerry Enterprise Server attempts to open the names.nsf file ten more times.  The following entries appear in the log:

[20222] (10/03 16:14:45):{0x10BC} Unable to get address book list - will try again in 1 minute (The remote server is not a known TCP/IP host. 0x1C63)
[10535] (10/03 16:15:47):{0x10BC} Unable to get address book list. Giving up after approximately 10 minutes.
[10432] (10/03 16:15:47):{0x10BC} Error initializing BES. Terminating.

Cause

When the BlackBerry Enterprise Server starts, it must open the names.nsf file from the IBM Lotus Domino Server on which it is running. To open the names.nsf file, it uses specific information from the server document. If this information cannot correctly open the names.nsf file, the BlackBerry Enterprise Server cannot start correctly.

 

Resolution

To resolve this issue, complete ALL the following steps:

Step 1 - Verify the Fully qualified Internet host name is resolvable

  1. On the computer hosting the BlackBerry Enterprise Server, open the server document for the IBM Lotus Domino Server.

  2. Select the Basics tab.

  3. Verify that the information in the Fully qualified Internet host name field is the correct name of the computer.

  4. Verify you can ping this address.

  5. If the ping is not successful, verify it resolves an internet protocol (IP) address and resolves the correct IP address of the computer.

  6. If it is does not resolve, verify the computer is configured in the Domain Name System (DNS) correctly.

Step 2 - Verify the netaddress field on the Ports tab is resolvable

  1. On the computer hosting the BlackBerry Enterprise Server, open the server document for the IBM Lotus Domino Server.

  2. In the Ports tab, verify that the netaddress field is resolvable and that you can ping the netaddress for any entry for the TCP/IP port.

Note: As a troubleshooting step, set the netaddress to the actual IP address of the computer.

 

Step 3 - Verify you can perform a IBM Lotus Domino trace from the BlackBerry Enterprise Server to another IBM Lotus Domino mail server in the environment

  1. Type the following command in the Domino Console:

    Trace <servername>

  2. If the trace is unsuccessful, visit the IBM Support website for additional assistance.

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