The BlackBerry device user receives the following error on the BlackBerry device during the enterprise activation process:
IT Policy Rejected. Please wipe handheld and try again.
The BlackBerry device rejects the IT policy that is pushed from the BlackBerry Policy Service.
This issue has more than one cause.
-
The BlackBerry device is activated on a BlackBerry Enterprise Server that is being upgraded from a trial version to a standard version.
- The BlackBerry device was previously active on another BlackBerry Enterprise Server and has a conflicting IT policy.
Resolutions
Perform the appropriate resolution for the cause.
Cause 1
The BlackBerry device is activated on a BlackBerry Enterprise Server that is being upgraded from a trial version to a standard version.
Resolution
Instruct the BlackBerry device user to use the Wipe Handheld option to erase all the data on the BlackBerry device. For instructions, see KB02318. This allows the BlackBerry device to accept a new IT policy.
Warning: All applications should be backed up before the BlackBerry device user uses Backup and Restore in BlackBerry® Desktop Manager. For instructions, see KB12487.
After all data is deleted from the BlackBerry device, remove the BlackBerry device user account from the BlackBerry Enterprise Server, and then add the account again.
Cause 2
The BlackBerry device was previously active on another BlackBerry Enterprise Server and has a conflicting IT policy. This occurs if the previous BlackBerry Enterprise Server and the current BlackBerry Enterprise Server do not share the same BlackBerry Configuration Database.
Resolution
Send a blank IT policy to the affected BlackBerry device. This should erase any existing IT policy setting. For more information, see KB05106.